Blue Eye Logo

Blue Eye Macro

Automation is freedom
It is currently Fri Dec 14, 2018 8:22 am

All times are UTC




Post a reply
Username:
Subject:
Message body:
Enter your message here, it may contain no more than 60000 characters. 

Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
Font size:
Font colour
Options:
BBCode is ON
[img] is OFF
[flash] is OFF
[url] is ON
Smilies are ON
Disable BBCode
Disable smilies
Do not automatically parse URLs
Please click and drag the 2 correct statements to the right hand side.
Please click and drag the 2 correct statements to the right hand side.
Please select the options below to the correct list to avoid automated registrations.
Statements
2 correct statements
Dogs have 4 legs
Fish can swim
Chickens can talk
Elephants can fly
   

Topic review - send hold keys not working
Author Message
  Post subject:  Re: send hold keys not working  Reply with quote
Oh, it won't...you'll have to use something like this:
Code:
 begin loop("10")
     Window.Send hold keys("Untitled - Notepad", "no", "Edit", "w")
     Macro.Pause("100")
     Window.Send release keys("Untitled - Notepad", "no", "Edit", "w")
 end

...or if you want it for a specific amount of time, you'll need to use a stopwatch.
Post Posted: Tue Dec 05, 2017 1:54 am
  Post subject:  Re: send hold keys not working  Reply with quote
sorry, forgot to login before replying.
Post Posted: Mon Dec 04, 2017 11:26 pm
  Post subject:  Re: send hold keys not working  Reply with quote
i already did that. it just types w instead of holding it down for 5 seconds.
Post Posted: Mon Dec 04, 2017 11:25 pm
  Post subject:  Re: send hold keys not working  Reply with quote
Got it...use "edit" like I said and it should work.
Post Posted: Mon Dec 04, 2017 8:58 pm
  Post subject:  Re: send hold keys not working  Reply with quote
the thing is, i want to make the key hold down. i don't want key presses. i want it to be held for 5 seconds then released.
Post Posted: Mon Dec 04, 2017 5:42 pm
  Post subject:  Re: send hold keys not working  Reply with quote
That's the wrong child index for Notepad; use "Edit" instead of "0" and it will work in Notepad.

Not sure what your trying to do, but I'd probably use "send keypress" instead of "hold key"...unless you know what your doing. I only use hold key for combinations of keys like shift+[a key] or ctrl+[a key]...if you're typing something out I would use send text or key presses.
Post Posted: Mon Dec 04, 2017 12:37 pm
  Post subject:  send hold keys not working  Reply with quote
i'm trying to create a macro that runs on an inactive window, but the key isn't pressing. you can see in this video: https://www.youtube.com/watch?v=4l7tiWEXuX4
It only presses in google chrome, but the key isn't holding.
Post Posted: Mon Dec 04, 2017 5:30 am

All times are UTC


Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group