Blue Eye Logo

Blue Eye Macro

Automation is freedom
It is currently Thu Jul 09, 2020 10:51 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: need some help
Thanked: 0 time(s)  Unread post Posted: Sat May 30, 2020 2:31 am 
New User
New User



Joined: Sat May 30, 2020 2:19 am
Posts: 2
Been thanked: 0 time(s)
Has thanked: 0 time(s)
Contribution Points: 11
Hello everyone. Before I get started Im sorry for 1)the noobish question and 2) for the long explanation .Have been racking my brain for the past 3 days trying to figure out how to efficiently do this and it seems every day I keep taking steps backwards when I think I am making progress. Hope someone can steer me in the correct direction.

So here is the gist of what I want to do: I have multiple Vms that I want to open one at a time, do some clicking and close out of the VM once im done. I've gotten the code pretty good for one of the VMs, however this is where I am encountering the issue. I can user the same set of scripts to do what I want to do in the VM but the only real changing variables are the window names and the coordinates needed to start each vm. I created a category and organized each one of the 4 vms, it looks like this:

-VMs
vm1
vm2
vm3
vm4

now the issue is I want to create one uber script that will take care of running each macos. Each vm has about 100 or so lines of code. When I just copy and past them all into one macros this start to break and not work right. So I started this:

begin
Macro.Execute new("VMs", "vm1", "yes")
Macro.Execute new("VMs", "vm2", "yes")
Macro.Execute new("VMs", "vm3", "yes")
Macro.Execute new("VMs", "vm4", "yes")
end


some times it will execute and other times it wont dont anything. When it does run it will only run the vm1 and wont move onto vm 2.

what am I doing wrong????

Thanks in advance!





EDIT: Never mind!!!!!!! Figured it out!!!!!!!!!!!!!!!!!

this code now words:
begin
Macro.Execute new("VM instances", "VM1", "yes")
end
when Window.Is not running("VM1", "yes")
begin
Macro.Execute new("VM instances, "VM2", "yes")
end


Top
 Profile  
Reply with quote  
 Post subject: Re: need some help
Thanked: 0 time(s)  Unread post Posted: Tue Jun 02, 2020 4:57 am 
Partner / License admin
Partner / License admin
User avatar



Joined: Sun Oct 10, 2010 5:16 pm
Posts: 2070
Location: USA
Been thanked: 466 time(s)
Has thanked: 35 time(s)
Contribution Points: 17120
Glad you got it figured out!!!

_________________
----------------------------------------Syrifina---------------------------------------------------
PM me for licenses and/or licensing information: Click Here
[Be sure to include and update your profile with your BE ID]

Forum Rules
Reminder of rules regarding Contribution points
Getting started in 1, 2, 3
Virtual Drivers; Manual Installers


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


You cannot post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group