Blue Eye Logo

Blue Eye Macro

Automation is freedom
It is currently Wed Oct 17, 2018 10:42 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: error unknown
Thanked: 0 time(s)  Unread post Posted: Tue Mar 20, 2018 4:09 pm 
New User
New User



Joined: Thu Mar 15, 2018 11:12 pm
Posts: 2
Been thanked: 0 time(s)
Has thanked: 0 time(s)
Contribution Points: 10
Checking if: Color.Pixel pattern can be located on screen near coordinate(Pattern: 102,75,43,0,-8,111,83,47, Range: 10, X Coordinate: 918, Y Coordinate: 1116, As near as: 10)
Error: Unknown
System.Runtime.InteropServices.ExternalException: A generic error occurred in GDI+.
at System.Drawing.Image.FromHbitmap(IntPtr hbitmap, IntPtr hpalette)
at System.Drawing.Image.FromHbitmap(IntPtr hbitmap)
at BlueEye.Wizard.Helpers.ScreenHelper.GetRegion(Int32 xFrom, Int32 xTo, Int32 yFrom, Int32 yTo)
at BlueEye.Macros.Helpers.ColorHelper.FindPattern(PixelPattern pattern, Int32 accuracyRange, Boolean center, Nullable`1 near, Nullable`1 range, Nullable`1 closestTo)
at BlueEye.Macros.Criterias.Color.Constraints.PixelPatternCanBeLocatedOnScreenNearCoordinate.IsSatisfied(IDictionary`2 variables)
at BlueEye.Macros.BaseClasses.BaseCriteria.<>c__DisplayClass1.<HasBeenMet>b__0(IConstraint c)
at System.Linq.Enumerable.All[TSource](IEnumerable`1 source, Func`2 predicate)
at BlueEye.Macros.BaseClasses.BaseCriteria.HasBeenMet(IDictionary`2 variables)
at BlueEye.Macros.MacroStep.evaluateCriterias(Macro owner, IDictionary`2 variables)A generic error occurred in GDI+.


please help


Top
 Profile  
Reply with quote  
 Post subject: Re: error unknown
Thanked: 0 time(s)  Unread post Posted: Tue Mar 20, 2018 7:23 pm 
Partner / License admin
Partner / License admin
User avatar



Joined: Sun Oct 10, 2010 5:16 pm
Posts: 1824
Location: USA
Been thanked: 391 time(s)
Has thanked: 31 time(s)
Contribution Points: 16331
There may be some things you can try, but that is a Windows API problem.

1. How fast/often are you searching for that pixel pattern. If you slow it down (add a macro.pause in there) it may help.
2. Reload .net framework 3.5
3. Otherwise it's a problem in Windows and you may need to reinstall Windows...unless you can find another fix online when the API starts flaking out.
- Are you running a genuine and licensed version of Windows?

_________________
----------------------------------------Syrifina---------------------------------------------------
PM me for licenses and/or licensing information: Click Here
[Be sure to include and update your profile with your BE ID]

Forum Rules
Reminder of rules regarding Contribution points
Getting started in 1, 2, 3
Virtual Drivers; Manual Installers


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


You cannot post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group