Blue Eye Logo

Blue Eye Macro

Automation is freedom
It is currently Sun Sep 20, 2020 3:30 am

All times are UTC




Post new topic Reply to topic  [ 12 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: "Stuck" characters and loop problem
Thanked: 1 time(s)  Unread post Posted: Tue Sep 15, 2020 1:40 pm 
Partner / License admin
Partner / License admin
User avatar



Joined: Sun Oct 10, 2010 5:16 pm
Posts: 2110
Location: USA
Been thanked: 488 time(s)
Has thanked: 37 time(s)
Contribution Points: 17260
Quote:
game client does not have any child windows so I set it to "0".
Considering you mentioned it has chat, it has to have child indexes; keyboard movement and chat cannot be on the same indexes...or every time you moved it would write in chat and vice versa. Maybe it's blocking you from seeing it, but I've never seen that before. I would make sure there's not a section you can expand further in Investigator. You could also try "edit" and "1"...unless you find the actual index.

One other thing you could try since you mention it worked with mouse hover, is sending the mouse hover: viewtopic.php?f=172&t=813

_________________
----------------------------------------Syrifina---------------------------------------------------
PM me for licenses and/or licensing information: Click Here
[Be sure to include and update your profile with your BE ID]

Forum Rules
Reminder of rules regarding Contribution points
Getting started in 1, 2, 3
Virtual Drivers; Manual Installers


Top
 Profile  
Reply with quote  
 Post subject: Re: "Stuck" characters and loop problem
Thanked: 0 time(s)  Unread post Posted: Wed Sep 16, 2020 1:29 am 
New User
New User



Joined: Sun Sep 06, 2020 12:08 am
Posts: 6
Been thanked: 0 time(s)
Has thanked: 3 time(s)
Contribution Points: 13
I got all excited when you showed me the hover mouse command but it still will not work. Could it be possible that the window has additional children indices even though it doesn't show up in investigator? I tried setting it to 1 and got this error in the log.

Executing: Color.Find coordinate of occurrence on screen closest to coordinate (RGB)(R: 99, G: 66, B: 132, Range: 0, X Coordinate: 364, Y Coordinate: 264, {X}: x, {Y}: y)
Executing: Window.Send mouse hover(Window ID/Title: Ragnarok1, Exact match: Yes, Child: 1, X Coordinate: 383, Y Coordinate: 333)
Error: Failed to locate child at index 1 since only 0 childen was available for the window named Ragnarok1

I'm determined to make this work I'll keep trying :x


Attachments:
12.PNG
12.PNG [ 7.79 KiB | Viewed 18 times ]
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page Previous  1, 2

All times are UTC


You cannot post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group